Partial application instability and 404 errors for some live pages
Incident Report for Instapage
Resolved
The issue has been traced to a DDOS attack, which has been handled by the team and all is working as expected now.
The app is stable and the affected pages should now be back up.
Posted Nov 14, 2022 - 09:19 UTC
Investigating
We are currently experiencing a partial outage at the application level and some live pages return 404 errors. Our team is working on resolving this incident as soon as possible, but we recommend pausing any paid traffic to your landing pages until this is permanently resolved.

We appreciate your patience and understanding while we are working on this.
Posted Nov 14, 2022 - 06:54 UTC
This incident affected: Landing Page Servers (pageserve.co, pagedemo.co, Landing Page Servers) and Application (app.instapage.com).