Application responsiveness difficulties
Incident Report for Instapage
Resolved
Our team managed to resolve the incident. The application is stable and fully functional now, however, there might still be inconsistencies regarding the page Preview mode.
We will keep monitoring the application and ensure that we eliminate any inconsistencies.
Posted Nov 26, 2019 - 18:00 UTC
Identified
We've noticed the application is currently experiencing a heavier load balance and parts of the application may take longer to load or won't load at all.
We have identified the root cause and are working on deploying a permanent fix, which will take effect shortly.
Please note that no live pages or leads have been affected by this.
Thank you for your understanding.
Posted Nov 26, 2019 - 14:48 UTC
This incident affected: Application (app.instapage.com).