Cloudflare API service outage causing issues with new subdomains connection & SSL encryption.
Incident Report for Instapage
Resolved
Cloudflare API services are operational: https://www.cloudflarestatus.com/

Enabling SSL certificates is possible again and connecting new subdomains should not pose issues going forward. If there is any delay with the SSL application, please reach out to our team.
Posted Nov 05, 2023 - 17:53 UTC
Investigating
Clients may experience issues with publishing pages on new subdomains. Subdomains recently set up via CNAME return an "ERR_SSL_VERSION_OR_CIPHER_MISMATCH" error on the live URL, due to inability to complete the connection and apply the SSL certificate.

More information on the Cloudflare status page: https://www.cloudflarestatus.com/.
Once we have more information about the progress, we will update this incident accordingly. Thank you for your patience!
Posted Nov 02, 2023 - 18:35 UTC