Instapage app and landing pages affected by Cloudflare API service issues

Incident Report for Instapage

Resolved

This incident has been resolved, and all services are working as expected.
Posted Dec 05, 2025 - 09:26 UTC

Monitoring

The Cloudflare team identified the issue and provided a fix. The landing page and the Instapage app are currently working. We are monitoring the situation.
Posted Dec 05, 2025 - 09:17 UTC

Identified

Cloudflare is down so the Instapage application and landing pages are down as well. You can also monitor their status here: https://www.cloudflarestatus.com/

Unfortunately, our ticketing system is also down because of this, so we are unable to respond at this time.
Posted Dec 05, 2025 - 09:06 UTC
This incident affected: Website & Blog (instapage.com), Application (app.instapage.com), Landing Page Servers (pageserve.co, pagedemo.co, Landing Page Servers), and Cloudflare (Cloudflare Authoritative DNS, Cloudflare Network, Cloudflare CDN/Cache).