Landing page slowdown and downtime
Incident Report for Instapage
Resolved
The attack was handled, and all is working as expected.
We will still be monitoring closely in case we will get attacked again. We are sorry if your pages got affected by this!
Our team will look for ways to prevent this from happening again.
Posted May 17, 2022 - 15:40 UTC
Monitoring
We have identified a DDOS attack on some pages that caused a heavy load on our servers, hence making less than 10% of the overall traffic have a slow loading time or not load at all.
Our team has stopped the attack, and we are closely monitoring the situation.
Posted May 17, 2022 - 15:21 UTC
This incident affected: Landing Page Servers (pageserve.co, pagedemo.co, Landing Page Servers).