Delayed Lead Delivery
Incident Report for Instapage
Resolved
Our systems are stabilizing, leads and notifications are being sent again.

We highly appreciate your patience.
Posted 11 months ago. May 16, 2018 - 11:26 UTC
Update
We are continuing to monitor for any further issues.
Posted 11 months ago. May 16, 2018 - 11:20 UTC
Update
We are continuing to monitor for any further issues.
Posted 11 months ago. May 16, 2018 - 11:18 UTC
Monitoring
Some users may experience delayed lead deliveries, for both email notifications and integrated third party software solutions, however, no data will be lost. A queue is being created and all the leads will be delivered, shortly after.

We will make sure to update you as soon as all the systems are operating at full capacity.

Thank you for your understanding.
Posted 11 months ago. May 16, 2018 - 10:07 UTC