Temporary Dashboard Downtime
Incident Report for Instapage
Resolved
The Dashboard is now fully operational and everything is back up and running. We apologize for the inconvenience this has caused!
Posted over 1 year ago. Mar 13, 2018 - 17:30 UTC
Identified
Our engineers have identified a temporary outage for the dashboard and are working to deploy a fix as we speak. Live pages have not been affected.
Posted over 1 year ago. Mar 13, 2018 - 16:43 UTC