Some live pages are inaccessible
Incident Report for Instapage
Resolved
The landing pages are back up and working now, but we will continue to monitor the situation. Please clear your browser cache if needed. If you experience any further issues, please reach out to our Support team.

Thank you for your patience and understanding on this matter.
Posted May 02, 2023 - 08:43 UTC
Identified
The issue has been traced to a DDOS attack which as been blocked. The affected pages should start working soon but we will monitor the situation and update accordingly
Posted May 02, 2023 - 08:12 UTC
Investigating
We have reports of some landing pages returning 502 server errors.

Our team is currently investigating this, but if you have been impacted, we recommend pausing any paid traffic to your landing pages until this is permanently resolved.
Posted May 02, 2023 - 07:55 UTC
This incident affected: Landing Page Servers (Landing Page Servers).