Delay on Lead Notifications emails.
Incident Report for Instapage
Resolved
We have processed all the queue of emails, and now everything is working and up to date.
We also started warming up a new email provider as a backup, but it will take a few weeks to handle the amount of emails we have. After that, we will be having multiple providers warmed up at all times in the future.
Posted May 29, 2024 - 09:16 UTC
Monitoring
The problem with our email provider has been fixed, and we have begun sending lead notifications successfully again.
Today, we are monitoring the situation, and tomorrow morning we will begin processing the queue of emails. Thank you for your patience while we worked to resolve this issue!
Posted May 28, 2024 - 17:52 UTC
Update
We are still waiting for an update from our email provider. The incident status remains unchanged, but we will update it accordingly once we have more information. We apologize for the inconvenience this ongoing issue may cause and appreciate your patience and understanding.
Posted May 27, 2024 - 17:07 UTC
Update
We switched to a backup email provider and transactional emails like password recovery and team invites are going out.
Lead notifications are still in the queue, as our email provider needs to complete some steps. We will update you as soon as we have some news. We appreciate your understanding!
Posted May 24, 2024 - 12:25 UTC
Identified
We are currently experiencing 403 errors from our email system provider, causing emails to be stuck in a queue. Our team has identified the issue and is working on a solution.
Please note that the emails are not lost; they will be sent, but there may be a delay. Thank you for your patience and understanding!
Posted May 24, 2024 - 07:32 UTC